こなさんち

しがないメンヘラエンジニアの日記。

AdminLte3 を Laravel に!

AdminLte3をインストール

背景

Laravelも、BootStrap4に対応したよ。

ということは、AdminLte2はBS3なので…どうせならBS4対応してるAdminLTE3入れてみよう。

インストール

AdminLTE2は

npm install admin-lte --save-dev 

で行けるかと思いきや、LatestはAdminLTE2なので、このままだとAdminLTE2がインストールされてしまいます。そのため、

npm install admin-lte@3.0.0-rc.1 --save-dev 

または

npm install admin-lte@v3-latest --save-dev

とバージョン指定する必要があります。

appに組み込み

以下を設定して、コンパイル

javascript

To resource/js/app.js

window.$ = window.jQuery = require('jquery');
require('admin-lte');

scss

To resource/sass/app.scss

@import '~admin-lte/dist/css/adminlte.min.css';